ubuntu 12.04 быть!

Вышла новая LTS ubuntu. Решил это я обновить свой 10.04 сервер на эту 12.04. Ну и заодно поменять жесткий диск на SSD.
Всё бы хорошо, только пока ждал диск, набрал do-release-upgrade, убунта предложила обновиться, отказался. и видимо зря. Из-за этого отказа система осталась 10.04, но репозитории оказались подключены от 12.04. Когда поставил ССД и начал разбираться, оказалось, что по команде apt-get dist-upgrade вываливается ошибка: «E: Internal Error, Could not perform immediate configuration (2) on python-minimal» . Причем этот питон сам устанавливаться не хотел. Проблема решилась командой

apt-get install python-minimal -o APT::Immediate-Configure=0

Следующая ошибка решилась ещё проще. На одном из пакетов говорило что-то про dpkg error blah-blah, решилось удалением пакета из кеша, на которое ругалось. В результате всех пертурбаций получил сервер 12.04, но ядро осталось старое 2.6, будем ещё разбираться.
update

sudo apt-get install linux-server

поставило последнее ядро. как всё просто оказалось 🙂

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Лимит времени истёк. Пожалуйста, перезагрузите CAPTCHA.